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ABOUT
This is the documentation for the Mattepainting Toolkit for Maya and the Camera Projection Toolkit for Maya
(MPTK and CPTK, respectively). Both of these toolkits are developed by Glyph Software and compiled
for Autodesk Maya. The Camera Projection Toolkit is released as a Module in the Maya App Exchange, and is
intended for all artists working with camera projections in Maya. The Mattepainting Toolkit is available here,
and includes more advanced camera projection features for artists working with photogrammetry in a
production environment.
Since there is a lot of crossover beteween the two toolkits, the documentation is combined in this Wiki,
referencing gs_mptk only, with notes about gs_cptk limitations where applicable.

WHY USE GS_MPTK AND GS_CPTK?
When texturing geometry in Maya, it is often preferable to use camera projections over UV placements, but the
limited toolset Maya provides is unintuitive and labor intensive. Combining multiple projections is cumbersome
and requires extra effort to paint holdout mattes to define explicit boundaries. Projection smearing, doubling
on backfaces, and loss of resolution over large surface areas are common problems that take time to patch.
gs_mptk removes the technical burdens of setting up projections in Maya and allows artists to focus on the
composition of the imagery. The advanced blending features of the toolkit are designed to target the challenges
of integrating multiple projections, and reduce the number of mattes needed to isolate geometry. gs_mptk was
built for mattepainters and texture artists, not programmers. A lot of consideration went into designing a
system that functions in an intuitive way, implements time-saving features, and minimizes repetition.

WHAT IS GS_CPTK?
gs_cptk is a limited-feature version of gs_mptk, intended for users who only care about managing and blending
multiple camera projections, not the full suite of tools available in gs_mptk. See the complete list of feature
differences in the following section. This wiki commonly refers to gs_mptk, and it can be assumed that the
information is applicable to gs_cptk as well unless notes are provided otherwise.

WHAT'S INCLUDED IN THE TOOLKIT?
• gs_projCamMix is the dynamically-loaded mental ray shader that forms the foundation of the Mattepainting
Toolkit and allows multiple projections to be blended based on a number of user-defined parameters.
• gs_occlusionMatteVRay and gs_projCamMixVRay together perform the same function for V-Ray as the
mental ray shader. These shaders are not available in gs_cptk.

• gs_hwTexture and gs_hwComposite are the Maya shaders that visualize projections in the 3D viewport using
OpenGL.
• gs_mptk_UI.mel is the MEL script that loads the interface to manage connections into gs_projCamMix, along
with additional features.
• gs_const is the constant Mental Ray shader that is assigned to the Maya shading engine, and receives the
output of gs_projCamMix.

Features

gs_mptk

gs_cptk

Blend multiple projections together

*

*

Blend projections using render occlusion masking

*

*

3D Viewport Projection Layering

*

*

Project sequences of frames

*

*

V-Ray shaders for rendering

*

Render Camera Coverage Maps

*

Photosynth Import

*

Point Cloud Data Import

*

Bundler Camera Data Import

*

WHAT DOES IT DO?
Simply, it blends multiple texture layers based on the blending parameters given to each texture. Viewport
shaders help visualize these texture layers in the viewport, and in addition, render-time-only occlusion masking
can be used with Mental Ray or V-Ray.
gs_mptk makes the process of setting up layered textures, and then managing their layer priorities, as
straightforward as possible through a custom user interface. gs_mptk also includes features to assist modeling
from projected images, a Structure From Motion data importer to reconstruct camera positions from
photographs, and other features useful for building 3D environments in Maya.

REQUIREMENTS
• Maya 2012, 2013, 2014, or 2015 Note: gs_cptk is only available for Maya 2014
• Mental Ray plug-in loaded (though not required for rendering)
• V-Ray plug-in loaded to use the gs_mptk V-Ray shaders
• OSX, Windows, or Linux

ADDITIONAL NOTES
• If you are using the V-Ray shaders with Maya 2012, you will need at least stable version 2.10.01 from
4/9/2012. Maya 2013 and 2014 does not have a version requirement.

INSTALLATION
Version 3.0 of the toolkit uses the Maya Module method of distribution for ease of installation. This allows the
toolkit to be installed in any directory specified by the environment variable MAYA_MODULE_PATH.
If you are upgrading from an earlier version of the toolkit, Make sure to completely remove the old version
before installing version 3.0 If you have a shelf labeled gs_mptk from an earlier version, delete this shelf from
within Maya before installing Version 3.0. Version 3.0 will automatically create a new shelf for you as long as
one doesn't already exist.
The paths below are given as default install locations for the toolkit.
The Mental Ray and V-Ray shaders must be installed separately from the gs_mptk module. Though it is not
necessary to install the V-Ray shaders, it is necessary to install the Mental Ray shaders in order for the toolkit
to load correctly.
As of Maya 2017, Mental Ray is available as a third-party renderer from nVidia. It is required to be loaded in
Maya for gs_mptk, and can be downloaded here: http://www.nvidia.com/object/nvidia-mental-rayproducts.html
Once installed, a gs_mptk shelf is created when Maya loads. The first button in the shelf will launch the user
interface.

OSX
Notes:
$USER in the paths below is the username on your machine.
$MAYA_VERSION in the paths below is the version of Maya you are running.
For Maya 2017 only, make sure Mental Ray is downloaded and installed prior to installation of
gs_mptk: http://www.nvidia.com/object/nvidia-mental-ray-products.html
From the module directory, copy the gs_mptk folder to: /Applications/Autodesk/$MAYA_VERSION/plug-ins
From the module directory, copy the gs_mptk.mod file to:
/Applications/Autodesk/$MAYA_VERSION/Maya.app/Contents/modules
copy the contents of shaders/mentalray/include to:
For Maya 2014: /Applications/Autodesk/mentalrayForMaya2014/shaders/include
For Maya 2015: /Applications/Autodesk/mentalrayForMaya2015/shaders/include
For Maya 2016: /Applications/Autodesk/mentalrayForMaya2016/shaders/include

For Maya 2016.5: /Applications/Autodesk/mentalrayForMaya2016.5/shaders/include
copy contents of shaders/mentalray/lib to:
For Maya 2014: /Applications/Autodesk/mentalrayForMaya2014/shaders
For Maya 2015: /Applications/Autodesk/mentalrayForMaya2015/shaders
For Maya 2016: /Applications/Autodesk/mentalrayForMaya2016/shaders
For Maya 2016.5: /Applications/Autodesk/mentalrayForMaya2016.5/shaders
for V-Ray users copy gs_mptk_desc.txt from shaders/vray to:
/Applications/Autodesk/$MAYA_VERSION/vray/shaders
for V-Ray users copy contents of shaders/vray/$VRAY_VERSION to:
/Applications/Autodesk/$MAYA_VERSION/vray/vrayplugins

WINDOWS
Notes:
$USER in the paths below is the username on your machine.
$MAYA_VERSION in the paths below is the version of Maya you are running.
The paths below are given for Windows 7. Other versions of Windows may have different paths.
For Maya 2017 only, make sure Mental Ray is downloaded and installed prior to installation of
gs_mptk: http://www.nvidia.com/object/nvidia-mental-ray-products.html
From the module directory, copy the gs_mptk folder to:
C:\Program Files\Autodesk\$MAYA_VERSION\plug-ins
From the module directory, copy the gs_mptk.mod file to:
C:\Program Files\Autodesk\$MAYA_VERSION\modules
copy contents of shaders\mentalray\include to:
For Maya 2014: C:\Program Files\Autodesk\mentalrayForMaya2014\shaders\include
For Maya 2015: C:\Program Files\Autodesk\mentalrayForMaya2015\shaders\include
For Maya 2016: C:\Program Files\Autodesk\mentalrayForMaya2016\shaders\include
For Maya 2016.5: C:\Program Files\Autodesk\mentalrayForMaya2016.5\shaders\include
For Maya 2017: C:\Program Files\NVIDIA Corporation\mentalray 3.14 for Maya 2017\shaders\include
copy contents of shaders\mentalray\lib to:
For Maya 2014: C:\Program Files\Autodesk\mentalrayForMaya2014\shaders
For Maya 2015: C:\Program Files\Autodesk\mentalrayForMaya2015\shaders

For Maya 2016: C:\Program Files\Autodesk\mentalrayForMaya2016\shaders
For Maya 2016.5: C:\Program Files\Autodesk\mentalrayForMaya2016.5\shaders
For Maya 2017: C:\Program Files\NVIDIA Corporation\mentalray 3.14 for Maya 2017\shaders
for V-Ray users copy gs_mptk_desc.txt from shaders/vray to: C:\Program
Files\Autodesk\$MAYA_VERSION\vray\shaders
for V-Ray users copy contents of shaders\vray\$VRAY_VERSION to: C:\Program
Files\Autodesk\$MAYA_VERSION\vray\vrayplugins

LINUX
Notes:
$USER in the paths below is the username on your machine.
$MAYA_VERSION in the paths below is the version of Maya you are running.
For Maya 2017 only, make sure Mental Ray is downloaded and installed prior to installation of
gs_mptk: http://www.nvidia.com/object/nvidia-mental-ray-products.html
From the module directory, copy the gs_mptk folder to:
/usr/autodesk/$MAYA_VERSION/plug-ins
From the module directory, copy the gs_mptk.mod file to:
/usr/autodesk/$MAYA_VERSION/modules

From the shader directory, copy contents of mentalray/include to:
For Maya 2014: /usr/autodesk/mentalrayForMaya2014/shaders/include
For Maya 2015: /usr/autodesk/mentalrayForMaya2015/shaders/include
For Maya 2016: /usr/autodesk/mentalrayForMaya2016/shaders/include
For Maya 2016.5: /usr/autodesk/mentalrayForMaya2016.5/shaders/include
For Maya 2017: /opt/nvidia/mentalray-3.14-for-maya-2017/shaders/include

From the shader directory, copy contents of mentalray/lib to:
For Maya 2014: /usr/autodesk/mentalrayForMaya2014/shaders
For Maya 2015: /usr/autodesk/mentalrayForMaya2015/shaders
For Maya 2016: /usr/autodesk/mentalrayForMaya2016/shaders
For Maya 2016.5: /usr/autodesk/mentalrayForMaya2016.5/shaders
For Maya 2017: /opt/nvidia/mentalray-3.14-for-maya-2017/shaders

for V-Ray users copy gs_mptk_desc.txt from shaders/vray to: /usr/autodesk/$MAYA_VERSION/vray/shaders
for V-Ray users copy contents of shaders/vray/$VRAY_VERSION to:
/usr/autodesk/$MAYA_VERSION/vray/vrayplugins

LICENSING
Two license files can be found in the licensing folder:
• gs_mptk_floating_license.lic This file should be copied to the host server if you are using a floating license.
• gs_mptk_local_license.lic This file should be copied to the client machine(s) whether you are using a floating
or node-locked license.

Node-locked Licenses
If you purchased a node-locked license, you only need to update gs_mptk_local_license.lic If you purchased a
floating license, skip to the Floating Licenses section below.
1) Open gs_mptk_local_license.lic in a text editor.
2) Replace the license key found in gs_mptk_local_license.lic with your license. Make sure to leave the first line
as "localhost"
3) Save the changes, and copy gs_mptk_local_license.lic to:
Windows Program Files\Autodesk\$MAYA_VERSION\modules
OSX /Applications/Autodesk/$MAYA_VERSION/Maya.app/Contents/modules
Linux /usr/autodesk/$MAYA_VERSION/modules
This is the default location the toolkit will search for the license file, but any path given by the environment
variable MAYA_MODULE_PATH can also be used. To see a full list of paths given by MAYA_MODULE_PATH,
you can run getenv MAYA_MODULE_PATH from the MEL Script Editor in Maya.
Alternatively, you can set the environment variable GSLIC to any path. The toolkit will first look to GSLIC to find
gs_mptk_local_license.lic, and then fall back to MAYA_MODULE_PATH if GSLIC is not set.
Note the $MAYA_VERSION given in the paths above will depend on what you have installed.
An example gs_mptk_local_license.lic will look like this:
localhost
a51530bbfbb5dc4c2b38e5ec846ac7a86db7c3ad
33ea5e8ac1c11d4780f1fec9a6c27c31a5579efa

Floating Licenses
Floating licenses use a server/client pair of files to validate the toolkit. These two files can be placed on the
same computer, or on networked computers. When using these two files across a network, make sure that they
are both accessible to each other using a file share, and that they both have full read/write privileges for all
users.
gs_mptk_local_license.lic and gs_mptk_floating_license.licneed to be updated with your license key.
The gs_mptk_floating_license.lic file is placed on the server. The gs_mptk_local_license.lic file is placed on the
client machine (artist workstation), and the path to the floating license file is supplied in the first line.
Follow these instructions:
1) Open gs_mptk_local_license.lic in a text editor.
2) Replace the license key found in gs_mptk_local_license.lic with your license key.
3) Replace the first line, "localhost" with the server location for the floating license file, e.g.:
OSX /Volumes/My HD/licenses/gs_mptk_floating_license.lic
Windows \\192.168.0.155\my_license_location\gs_mptk_floating_license.lic
Linux /192.168.0.155/my_license_location/gs_mptk_floating_license.lic
Note: Make sure to include the filename gs_mptk_floating_license.lic at the end of the path, as indicated above.
For OSX, the path should follow the syntax given by the Finder (use Get Info on a folder for specific location
syntax).
4) Save the changes, and copy gs_mptk_local_license.lic to the following locations on all client
machines running the toolkit, or to the network install location:
Windows Program Files\Autodesk\$MAYA_VERSION\modules
OSX /Applications/Autodesk/$MAYA_VERSION/Maya.app/Contents/modules
Linux /usr/autodesk/$MAYA_VERSION/modules
Any path given by the environment variable MAYA_MODULE_PATH can also be used in place of those above.
To see a full list of paths given by MAYA_MODULE_PATH, you can run getenv MAYA_MODULE_PATH from the
MEL Script Editor in Maya.
Alternatively, you can set the environment variable GSLIC to any path. The toolkit will first look to GSLIC to find
gs_local_license.lic, and then fall back to MAYA_MODULE_PATH if GSLIC is not set. This may be preferable for
custom network installations of Maya.
Note the $MAYA_VERSION given in the paths above will depend on what you have installed.
5) Open gs_mptk_floating_license.lic in a text editor.

6) Replace the contents of the first line of gs_mptk_floating_license.lic with the second line of your license
key only.
For example, if your license is this:
a51530bbfbb5dc4c2b38e5ec846ac7a86db7c3ad
33ea5e8ac1c11d4780f1fec9a6c27c31a5579efa

gs_mptk_floating_license.lic should look like this:
33ea5e8ac1c11d4780f1fec9a6c27c31a5579efa

7) Save the changes, and copy gs_mptk_floating_license.lic to the server location you specified on the first line
of gs_mptk_local_license.lic above.
8) Share or mount the folder containing gs_mptk_floating_license.lic with all client machines running the
toolkit. Make sure the floating license location is accessible from the machine you're running gs_mptk, or
gs_mptk will revert to demo mode.
9) Make sure that both of the license files have read/write access, or gs_mptk will revert to demo mode.
An example floating license setup is given below. Note the actual IP Addresses and license files will depend on
your setup.
An example gs_mptk_local_license.lic will look like this:
\\192.168.0.155\licenses\gs_mptk_floating_license.lic
a51530bbfbb5dc4c2b38e5ec846ac7a86db7c3ad
33ea5e8ac1c11d4780f1fec9a6c27c31a5579efa

...and will be copied to the Resources folders of the Maya installation on all client machines running the toolkit.
An example gs_mptk_floating_license.lic will look like this:
33ea5e8ac1c11d4780f1fec9a6c27c31a5579efa

...and will be copied to \\192.168.0.155\licenses

TROUBLESHOOTING LICENSES
When you load the gs_mptk shaders, they will print info about the license status, either into the Output Window
on Windows, or the shell you launched Maya from on OSX.
If you run into a licensing error, gs_mptk will run in demo mode, and you should refer to the status printouts for
more information.
For nodelocked licenses, you can check the status of your MAC address by typing ipconfig (windows) or ifconfig
(OSX and linux) in a shell or command prompt.
For floating licenses, make sure the location of the license server is accessible from your local machine. Try to
connect to the location directly and map the network drive if the license error printouts indicates issues
connecting to the license server.

You can test whether the license error has been corrected by simply closing the scene file that is using gs_mptk,
and re-opening it; you do not need to exit Maya altogether.
gs_mptk will run in demo mode when a license error has occurred, or if the number of available licenses are all
in use.

LOADING GS MPTK
1) Launch Maya. A shelf tab labeled "gs_mptk" is created automatically. This tab contains
user interface.

to launch the

This
button will crawl the scene objects and auto-rename any objects with duplicate names. Since
gs_mptk requires unique names, this tool should be run in the event that the following error is thrown when
using the toolkit: Error: More than one object matches name.
2) Make sure Mental Ray is loaded from the Plug-in Manger: Window>Settings/Preferences>Plug-in
Manager>Mayatomr.mll. This is a requirement for the toolkit to run properly, even if you're not using Mental
Ray to render.
3) If rendering with V-Ray, load the V-Ray Shaders:
Window>Settings/Preferences>Plug-in Manager>gs_occlusionMatteVRay.mll
Window>Settings/Preferences>Plug-in Manager>gs_projCamMixVRay.mll
Optional: If you prefer to remove the gs_mptk shelf, you can remove the file gs_mptk_load.mel from
[MAYA_INSTALL_LOCATION]/plug-ins/gs_mptk/scripts
In this case you will need to source gs_mptk_UI.mel (also found in [MAYA_INSTALL_LOCATION]/plugins/gs_mptk/scripts) from the Script Editor to load the UI.
4) Make sure Viewport 2.0 is set under the Renderer menu in the viewport panel.

5) Launch the user interface from the gs_mptk shelf by clicking the

button.

THE UI
The UI is a floating window that manages all aspects of the toolkit. It is loaded by clicking the
the gs_mptk shelf. Alternatively, you can source gs_mptk_UI.mel through the script editor.

button on

Make sure the gs_projCamMix shader is loaded in Window>Rendering Editors>mental ray>Shader Manager, or
the script will return the Warning: Unknown object type: gs_projCamMix

When the UI loads, all gs_projCamMix shaders existing in the current scene are loaded into a tabbed layout,
with the tabs labelled according to the shader names. The textures and mattes available to each shader are
displayed within these tabs, along with their associated attributes and objects to which the shader is assigned.

Contents
Menu

File

Command

Function

Import...

Will import SFM data with the .out extension (coming from Bundler,
Photosynth, Agisoft Photoscan) or .ply data saved in the ASCII format. If
you are unsure whether your .ply data is ASCII, open it in a text editor to
see whether it is human-readable. See the Importing Point Clouds and
Cameras for more information.

New Shader

Will create a new shader.

Select Layered
Texture

In addition to the Mental Ray and V-Ray shaders, gs_mptk creates a
Layered Texture with all of the texture inputs for rendering in other
renderers. This menu option will select that layered texture so that it can
be connected to your shader of choice.

MPTK tries to keep track of shading network dependencies and remove
unnecessary nodes when they are no longer needed, but sometimes
Delete Unused Nodes
nodes are left dangling. This cleanup option will attempt to remove any
shading nodes created by gs_mptk that are no longer in use.
Will render a coverage map from the current viewport perspective that
shows which areas of the selected geometry are visible to the selected
Create coverage map camera over the time range specified in the timeline. Select a camera and
a any number of objects before invoking this command. The resulting
render adheres to the settings of the Render Settings.

Options

Close

Close the UI.

Build V-Ray Shaders

When enabled, V-Ray shading networks will be created for all texture
groups. The networks will be updated whenever a change is made to the
Texture Attributes.

File Filtering

Will set all files associated with the texture group to the selected filtering
method. This is for rendering only; filtering changes are not visible in the
viewport.

Viewport Layering

When enabled, up to 16 textures in the Texture List will be displayed in
the viewport. The total number of displayed textures is dependent on your
graphics card texture units.

Help

Debug Mode

Enable to print messages to the Script Editor for any modifications made
to the projections through the UI.

Debug Step

Enable to pause after each command is invoked during modifications
made to the projections through the UI.

Documentation

Launch a browser to load this Wiki.

About

Display version info.

TABBED LAYOUT
Under the top menus, a series of buttons allow for control of the shaders the toolkit uses for viewport display
and rendering. These are represented in a tabbed layout, where the name of the tab corresponds to the
compositing shader used at render time. By default, this shader is labeled "gs_projCamMix."
Button Icon

Function
Add a new composite shader. This will create a gs_projCamMix shader with camera
projection by default.
Remove the composite shader from the scene, along with any associated connections. The
shader represented by the currently selected tab will be removed. All nodes with
connections to the group, except cameras, will be deleted.
Select the composite shader in the scene. This will select the gs_projCamMix shader of the
currently selected tab, allowing for easy access to it within the Hypershade. Tip: once the
selection is invoked, open the Hypershade and go to Graph>Input and Output Connections
to graph the shader and its connections.
Rename the composite shader.
This will bake the shader to the UVs of the selected objects. Selected objects must also be
added to the Object List so that proper shader assignments are made. See the Baking
Textures section of the documentation for more information.

TEXTURE LAYERS
The Texture Layers list represents all of the textures connected to the color inputs of the gs_projCamMix
shader. The images in this list will constitute the RGB of the render, and are ordered in a top-down priority so
that textures higher in the list will composite over those below. In other words, textures are layered on top of
each other from the bottom of the list to the top. You can access the texture attributes of the individual textures

in the Texture List by clicking the
button. This will highlight the texture in the Texture Layers and load the
attributes of that texture in the middle pane of the UI.
Button Icon

Function
Add a new texture layer.
Remove the active (highlighted) texture.
Select the active (highlighted) texture.

Each texture in the list has a thumbnail preview on the left, a name that corresponds to the texture itself
(editable), the path to the image on disk (editable), a
to make the texture active and load its attributes.

button to browse for images on disk, and a

button

Image sequences can be loaded by shift-selecting the start and end frames in the image browser dialog that
is invoked with the
button. Non-contiguous selections can be made by ctrl-selecting (cmd-selecting on
OSX) the images to load, which can be useful to load only every Nth frame in a sequence. Once a sequence is
selected, the toolkit will ask for a sequence start frame in the timeline, which allows you to set a different
timeline start frame than the sequence numbering.
In Windows and OSX, clicking on the thumbnail preview of a texture in the Texture List will launch the image
editor specified by the user in Window>Settings/Preferences>Preferences>Applications. This feature is not
available by default in Linux.
When a file texture with an alpha channel is added to the projection with the
button, its alpha channel is
detected and the user has the option to add the alpha channel to the Additional Mattes list. Note that a file’s
alpha channel is not detected when editing the path field directly.
Textures in the list can be reordered by middle-mouse dragging them to the desired position. Textures can be
swapped by shift-middle-mouse dragging from one index to another. Note that the drag-drop area of the
projections does not include the field areas.
When a textures is added to the list, a gs_hwTexture shader is added to visualize the projection in the viewport.
Similarly, when the
button is used to select a texture, it will be displayed in the viewport, overriding the
previous viewport texture, unless Viewport Layering is enabled. Regardless of whether viewport layering is
enabled, clicking the

button will load that texture layer's attributes in the UI.

When Viewport Layering is enabled in the Options menu, up to 16 projections in the Texture List will be layered
in the viewport, just as they will be layered in the render. The texture at the top of the texture list is the dominant
texture, and the 15 textures below it are layered on top of each other in successive order, based on their mattes.
Though 16 textures is the maximum the toolkit will display in the viewport, your graphics card may have other
limitations. When Viewport 2.0 is first initialized, you can see how many textures your card is capable of
displaying by checking the "Max tex coords" value in the Output Window (Windows) or terminal (OSX and Linux).
Also note that while there are a limited number of textures visible in the viewport, there is no limit to the number
of textures in the texture list that will render. The mattes of each texture in the texture list determine how they
will composite with the textures below them in the list. Additional mattes for the selected texture layer, which

are only visible in the render, can be set in the Render Attributes. See the Rendering
more info.

Attributes section for

TEXTURE ATTRIBUTES
This section of the UI lists all attributes available for the active (highlighted) texture in the Texture Layer.
UI Section

Attribute

Operation

Mapping

UV

UV mapping will use the object UVs to map the texture.

Spherical
Projection

This mapping type will project the texture spherically from the assigned camera.
This is useful for HDRI maps. Make sure to use equirectangular
(latitude/longitude) maps in aspect ratio 2:1 for this mapping type to project
correctly.

Camera
Projection

This mapping type will perform a perspective projection from the selected
camera. Note the texture is projected according to the camera FOV, not the image
aspect ratio.
This button will assign the currently selected camera to the current texture as
long as the Spherical or Camera Map Types are selected.

Camera

Common
Attributes

Camera
button

The camera that is projecting the active texture is displayed here. Clicking the
button will select the camera in the scene.

Color
Offset

This color picker will add color to the current projection image. It is useful to help
balance textures that have a slightly different exposure or hue from others in the
list, or to make radical changes that expose the texture's contribution amongst
other layers.

Pass
Through

This check box will bypass the current texture, effectively removing its
contribution from the texture layers.

If your texture RGB is mixed with black from a matte, you will want to disable
Premultiply to prevent black edges when the texture layers are blended together.
Premultiply If your texture RGB is not mixed with black--i.e. your texture is a photograph but
you are applying a matte to mask portions of the texture--you will want to enable
Premultiply to prevent the texture from additive mixing with other texture layers.

Matte

The
Texture
Matte

The Matte section of the UI determines how the current active texture will be
masked against other other textures in the Texture List. You can think of the
Matte as an image file performing the role of an alpha channel for the RGB
components of the active texture. Since the Matte is a separate image, however,
you have the benefit of choosing which channel (R,G,B, or A) of the image file you
want to use to mask the RGB components of the active texture. This allows you
to store 4 total mattes in one image file. By default, a Maya Ramp procedural
texture is set as the matte, and since it has a value of 1.0, the active texture will
be 100% opaque. When a matte is loaded with the

button, the toolkit prompts

the user to choose which channel to use, and the ramp is then replaced by a the
chosen channel of the file texture. If you want to paint a matte in the viewport,
you can click the
button to enter Maya's paint mode. See the Painting
Mattes section for more details. The Maya file node that loads the matte can be
selected with with
Rendering
Attributes
(Mental Ray
and V-Ray
only)

button.

Distance
Threshold

When this field is set > 0, the current projection will only project onto geometry
that falls at a cm distance less than the value set. This value is always read as
cm, and does not convert to other working units set in the preferences.

Use
Shadow
Occlusion

When checked, geometry not seen by the projection camera are masked at render
time. These masked areas will be filled by the next projection in the list if it is
visible to the camera of that projection. In this way, the gs_projCamMix shader
works from the top of the projection list down to the bottom, filling in masked
areas with the next projection that is able to “see” them. This feature is called
“shadow occlusion” because the projection camera acts like a light to determine
what areas of the geometry are shadowed. In order for this feature to work,
raytracing must be enabled in the Render Settings. The following attributes are
enabled with shadow occlusion:

Dilate

This attribute will expand the shadow area. Since it is often difficult to have a
perfect correlation between the edges of a projected texture and geometry edges,
the dilate attribute can conceal edge bleeding by expanding the shadow mask.

Samples

This attribute sets the number of samples per pixel for the shadow mask. It
should be enabled only when Soft Edge is > 0.

Soft Edge

This attribute creates adds feathering to the dilated shadow area. It is bound to
a 0-1 range, where 1 is maximum feathering.

Power

This attribute adds density to the Soft Edge. It is often preferable to increase the
Power when using Soft Edge to ensure that the dilated area produces a solid
matte at the geometry’s shadow boundary.

This attribute will prevent the current projection from projecting onto geometry
Use Facing backfaces when Angle Threshold = 90. If Angle Threshold < 90, areas of the
Ratio
geometry visible to the projection will be masked as well. Facing Ratio produces
a mask with a value of either 0 or 1, depending on the Angle Threshold.

Angle
Threshold

The Angle Threshold extends the backface culling to include front faces, based
on the angle between the camera view vector and the geometry normal. It is
specified in degrees, from 0 to 90. It is often advantageous to use backface
culling with projections, and this is achieved by enabling Facing Ratio and setting
the Angle Threshold to 90. Sometimes, however, it is also necessary to mask
geometry that is visible to the camera at a grazing angle so that projected

textures do not smear across the geometry. This is achieved by setting the Angle
Threshold < 90.

OBJECT LIST
This list displays the names of all objects (geometry) associated with the gs_projCamMix node. Since the
gs_projCamMix node is identified as a Mental Ray texture, it does not have a shading engine and does not make
direct shading assignments. Instead, an output connection is made between the gs_projCamMix node and
another shader that is assigned to the geometry. In this way, the gs_projCamMix node can easily fit into a
pipeline that has custom shaders.
It is necessary to add geometry to the Object List in order for them to render.
The Object List allows for multiple selections by either click-dragging, shift-clicking, or, for non-contiguous
selections, ctrl-clicking (cmd-clicking on OSX). If shader assignments are made to geometry outside of the UI,
it is necessary to refresh the UI in order to see these changes reflected in the Object List.
Button Icon

Function
To add an object to the Object List, gs_projCamMix must have at least one outgoing
connection to a shader connected to a shading engine. If no outgoing connections are
found, a default gs_const shader is created and connected to .outColor of the current
gs_projCamMix node. This button can also change shader assignments to objects already
in the Object List. For example, if there are multiple outgoing connections from
gs_projCamMix to different shaders, any object in the list can by assigned to a different
shader because the list of connected shaders is invoked every time the + button is pressed.
Note that only shaders with incoming connections from gs_projCamMix and outgoing
connections to shading engines are detected by the + button. Shaders are connected to
shading engines by default when they are created through the Hypershade, so this is not
usually an issue.
This button will remove the shader assignment from the geometry selected in the list.
This button will select the geometry selected in the list.

HOW SHADOW OCCLUSION WORKS
Shadow Occlusion is a feature of the toolkit available for the Mental Ray and V-Ray renderers. It is intended for
camera perspective projection only; using shadow occlusion with spherical projections is not advised.
The geometry’s shadow boundary is the hard edge between the visible and invisible areas seen from the
projection camera. When you dilate this shadow area, you are masking areas that are seen by the projection
camera, and allowing other textures lower in the texture list to fill this area. By enabling Soft Edge, you are
adding transparency into this dilated area, but not the hard shadow area that is not seen by the projection
camera. With transparency in the mask, a percentage of the current texture’s contribution will be mixed with
the textures lower in the list that are able to see this dilated area. The Power attribute weights the percentage
blending in favor of projections lower in the list. Increasing the Samples will produce a smoother (less noisy)
blend at the expense of render time.

PAINTING MATTES
The
button in the Matte section of the Texture Attributes will allow you to interactively paint mattes on
geometry in the viewport.
When this button is first clicked, the active texture will disappear from the viewport. The reason for this is a
paint matte has been applied with a value of 0.0, thereby making the RGB texture 100% transparent. To bring
the texture back, double-click the
button from the tool bar on the left side of the Maya interface. This will
bring up the 3D Paint Tool Settings. From the Tool Settings, find the Flood rollout section, set the Flood color
to white and click the Flood button. The matte now has a value of 1.0, and your active texture should be visible
again in the viewport.
You can "erase" the RGB values of your active texture by painting values < 1.0 in the viewport. To do so, open
the Color rollout section from the 3D Paint Tool Settings and set the color to black. Now paint on the geometry
in the viewport and you will "erase" the color of the active texture. What you're really doing here is painting a
grayscale map of values, where white represents complete opacity, black represents complete transparency,
and all values in between represent varying levels of transparency. You can change your brush width by holding
down the "b" key on the keyboard and click-dragging in the viewport.
When you are satisfied with how your active texture is blending on your geometry, you can select the "Save
Changes" option from the floating gs_mptk "Paint Matte is Active" window. Note that while in 3D Paint mode,
you can not choose any other tools, such as Translate, Scale, Rotate, etc. Doing so will disable the Paint Matte
tool and disregard any painting you have already done.

IMPORTING POINT CLOUDS AND CAMERAS
The Mattepainting Toolkit allows users to import PLY and Bundler data produced by a number of Structure
From Motion software packages, such as Agisoft Photoscan and Photosynth.
PLY data that contain point clouds are imported as Particle Shapes into Maya. Note that only ASCII PLY data
can be imported. Binary PLYs are not supported.
Cameras can by imported into Maya from Bundler .out files.
Both PLY and Bundler .out files are imported into Maya through the File>Import... option in the MPTK UI. Note
that you may need to switch the file filter in the import dialog box to see the files for import. When you import
Bundler camera data, a dialog box will appear prompting for more information. You will need to provide the
toolkit with the camera sensor size (film back) that produced the images in the bundle, as well as the image
resolution size. The toolkit will prompt you for this information.
When importing Cameras from Bundler files, the toolkit will give you the option to automatically create camera
projections for all of the cameras in the bundle. This is not advised unless only a few cameras exist in the
bundle, as it can severely impact performance. The preferred method is to create the camera projections
selectively once the import has completed.
When importing PLY point cloud data, you have the option of choosing a Step Size. This option will skip every
Nth point in the dataset. Unless you know for sure that the point cloud dataset is sparse, you should try using
a large step size (start with 100) since import will get progressively slower with a high number of points. You
can always delete the resulting particle shape and re-import with a lower step size to increase the fidelity of
the point cloud. Currently Maya Viewport 2.0 does not support particle colors, but the legacy default renderer
does. To see color in your point cloud, switch the viewport renderer back to legacy.

BAKING TEXTURES
If you want to bake the result of the texture layers down to object UVs, select the geometry you want to bake,
and click the
button at the top of the MTPK UI. Note that only one map will be baked, so if you have multiple
objects selected, you will want to make sure that their UVs do not overlap. Textures are only baked in the 0-1
range, so if you have object UVs outside this range, they will not be baked. A Save As... window will allow you
to choose your resulting bake file location, and in this window you can set the output resolution. Note that this
option is only visible when using the Maya-style dialog box (this preference can be set in Maya
Preferences>Settings>Files/Projects>File Dialog>Maya default). Optionally, choose the anti-aliasing option
from the Save As window to smooth the edges of your bake map, but be aware that this may produce black
edges along your geometry seams.

USAGE AND TROUBLESHOOTING
Once you have loaded the User Interface and assigned at least one texture to geometry, you can render with
Mental Ray. To render with V-Ray, make sure that Build V-Ray shaders is enabled in the MPTK UI Options
menu.
The advantage of rendering with Mental Ray or V-Ray is that you have the additional Rendering Attributes to
create raytraced mattes for each texture layer. gs_mptk also manages an additional layered texture network,
however, for rendering with other renderers when the Rendering Attributes are not needed. To render with Maya
Software or other third party renderers, choose Select Layered Texture from the File menu in the MPTK UI, and
then once the Hypershade opens, graph Input and Output Connections. This will make the layered texture
visible in the Hypershade Work Area. Then follow these steps:
1) Connect the color (and/or alpha) output of the Layered Texture to a shader of your choice.
2) Create a new render layer, and select it so that it becomes the active layer.
3) Assign the shader you created to the geometry.
This way, you can continue to use the gs_mptk UI from the Master Layer, but render from the additional render
layer using the renderer of your choice.

KNOWN ISSUES
At scene scales > 4999 cm units, Viewport 2.0 does not properly render camera projections. This is a known
Maya bug, and has been logged with Autodesk engineers as critical issue MAYA-42209. The current
workaround is to parent all geometry and cameras under a parent null and scale down to < 5000 cm units. This
issue does not affect rendering, so the scene can be scaled back up if viewport rendering is not needed.

VERSION HISTORY
1.25.17
• Version 3.1.3 Released for Maya 2017. Mental Ray must now be installed as a third-party renderer from
nVidia: http://www.nvidia.com/object/nvidia-mental-ray-products.html
9.16.15
• Version 3.1.3 Released for Maya 2016. Minor UI fixes.

• Delete Paint Mattes button now works on OSX.
• Added Alpha Bake option.
• Renaming file name paths fixed.
• Viewport layering toggle value state remembered when re-opening UI.
• Thumbnail update option added to Options menu.
• Rendering attributes layout now properly sets enable and disable states for occlusion and facing ratio options.
• Added extra shader baking features: alpha, udim, full UV range, color depth.
• Fixed removing objects from Object List when intermediate shapes exist.
6.15.14
• Version 3.0 Released. Viewport 2.0 is now the default, and the legacy Default Renderer is only supported in
earlier versions of the toolkit.
5.17.13
• Build 23132291 for Maya versions 2013, 2013.5 and 2014 released. Maya version 2012 is locked at build
19132284, released 8.6.12.
5.16.13
• Image sequences now supported for additional mattes list
• Improved shading connection handling for projections using alpha channels in the additional mattes list
5.9.13
• Fixed shading connection bug when enabling V-Ray Rendering for the first time (vraySpecificSurfaceShader
attribute not found error).
• Film back offset, film aperture, and film fit type on cameras now automatically update the viewport shader
when changed (no refresh required).
5.3.13
• V-Ray RT now supported.
• Alpha channel of V-Ray renders now correctly matches projection masks.
• Projected image sequences no longer require the UI to be open for updating when the current time is changed.
4.1.13
• Fixed layering bug when shadow occlusion was enabled.
• Removing a camera from the UI no longer deletes animation keys.

• Closing and re-opening the UI now remembers viewport shading assignments when multiple shaders exist in
the scene.
• A new gs_cleanGeoNames.mel script is included to help fix duplicate shape names on geometry that prevent
them from being added to the Objects List in the UI.
• Maya 2013 OSX version now supports OpenEXR in the viewport.
8.9.12
Released a patch to gs_mptk_UI.mel
• Animated sequences now display properly.
• Layering with more than 7 projections now works properly.
• Renders now layering projections when using auto-assign projections from SFM import.
8.6.12
New Features
• V-Ray integration
• Photosynth integration
• Animated sequences are now supported for projections.
• Multiple projection layering in the viewport.
Bug Fixes
• gs_mptk_UI assumes images with alpha channels that are added to the projection list should set shader
transparency by default.
• gs_mptk_UI will not crash when adding projection cameras that have constraints.
• Multiple projection groups now composite properly.
• Geometry can now self-occlude in masking operations.
• Camera import from SFM data now does a proper matrix decomposition for all camera orientations.
Deprecations and Limitations
• miLabel is not supported in masking operations.
6.20.11
• Maya 2012 version is compiled.
• Fixed an aspect ratio bug in the Mattepainting Toolkit that was causing the viewport to stretch projections in
some situations.
• Floating license option becomes available, in addition to node-locked licenses.
• Importing Bundler and PLY data is available for demo versions.
10.1.09
• The first version of the Mattepainting Toolkit is released.

BEST PRACTICES
The following is a list of workarounds and optimizations for effective use of the tools.
If you can't add geometry to the Objects List, the problem is likely that you have more than one
Shape node with the same name existing in your scene file. The toolkit relies on unique names for all geometry
to ensure correct shading connections. You can click on the

button in the gs_mptk shelf, to crawl through

your scene file and rename any duplicate shape nodes, then refresh the UI by clicking the
shelf and try to add the object to the Objects List again.

button in the

gs_mptk will perform an Over operation when compositing images together. Take note of the
Premult switch described above to avoid double multiplication of mattes. Transparency operations are
calculated with raytracing. Make sure raytracing is enabled in your renderer when calculating transparency.
When compositing multiple layers of transparency, make sure to have your raytracing limits set
high enough to avoid early termination of the ray. Refer to Mental Ray and V-Ray documentation for more
information on raytracing limits.
When using shadow occlusion with the Dilate option, be aware that render times can increase
significantly. This is due to the increase in rays probing for occluding geometry, and is directly related to an
increase in Dilate and Samples values. Keep these attributes as low as possible. Mental Ray and V-Ray use
different algorithms for sampling, so there will be a visual difference in the mattes generated with this feature
of the toolkit.
If you notice black edges in the V-Ray shadow occlusion of transparent images, disable Filter
Maps under Render Settings>VRay tab>Global Options>Materials>Filter Maps
You do not have to use gs_const (Mental Ray) or the default Maya Surface Shader (V-Ray) that
is added at the end of the shading network by default. To use other shading models, connect the relevant
outputs of gs_projCamMix to your material shader of choice. The advantage of the default materials created
by gs_mptk_UI is that they are fast and reliable. They do not, however, take lighting calculations into
consideration. To get lighting evaluation, you will have to connect the outputs of gs_projCamMix to your shader
of choice. Note that when using custom shaders, gs_mptk_UI will have no knowledge of these connections,
and may therefore become unreliable. It is therefore suggested that changes to the shading network should
only be performed as a last step before rendering.
When using custom shaders in place of gs_const (Mental Ray), make sure to connect the
outMatte and/or outTransparency plugs to your custom shader, or Mental Ray may not evaluate transparency
operations correctly.
To help V-Ray Shadow Occlusion artifacts, select the mesh producing the artifacts, as well as
the occluding object, and in the Attribute Editor, add Attributes>VRay>Subdivision and Displacement Quality,
as well as Subdivision. Then lower Edge Length.

V-Ray transparency tracing can be slow to render. One option to increase render speed is to
set the transparency cutoff to 1 in Render Settings>VRay>Global Options
When rendering with Mental Ray, set raytracing limits to 1 unless you need multiple ray
intersections (multiple layers of transparency, for example). This will greatly decrease render times.
In some cases, alpha channels are not detected by gs_mptk_UI. This is related to the Maya
function fileHasAlpha returning 0. If an alpha channel of your projection is not detected by default, add it to the
Additional Mattes list manually.
Importing Bundler files requires the decomposeMatrix plugin that ships with Maya. Go to
Window>Settings/Preferences>Plugin Manager and make sure MatrixNodes is loaded.

FAQ
Why can't I see textures in the viewport?
If you're using version 3.0 of the toolkit, make sure you're using Viewport 2.0. Then, make sure you're in shaded
mode ("6" on the keyboard.) If your texture is still not displaying correctly, make sure you're using OpenGL as
your Rendering Engine: Windows>Settings/Preferences>Preferences>Display>Viewport 2.0>Rendering Engine:
OpenGL - Legacy. You will need to restart Maya if you change your Rendering Engine preference. If you're using
gs_mptk version 2.0, you must be in Default Rendering in order to see the textures displayed.

MPTK seems to run slowly and/or texture thumbnails are not updating in the UI.
Open the Maya Preferences, and under the Display preferences, make sure your Render Swatches resolution is
greater than your texture resolution. You will need to restart Maya for this change to take effect. Note that this
may cause the User Interface to slow down thumbnail updates if you are using a lot of high resolution textures.
Setting the texture limit lower should improve performance.

How can I use Arnold to Render?
The best way to use renderers other than Mental Ray or V-Ray is to create a separate Render Layer and assign
the output of the gs_mptk Layered Texture to your shader of choice. This way, you will still be able to work with
gs_mptk in the Master Layer. From the gs_mptk UI, go to File>Select Layered Texture. This will open the
Hypershade and select the Layered Texture that gs_mptk manages for third party renderers. Graph the input
and output connections to see the Layered Texture in the workspace.

When I try to add geometry to the Objects List through the UI, no geometry shows up.
This is most likely due to a failure of one of the plugins to load properly. Check to make sure you have all of the
plugins loaded, that Mental Ray is loaded, and that gs_projCamMix is loaded as a mental ray shader.

My license isn't working. I can only run the toolkit in demo mode. Help?

Refer to the licensing section of this document.

Why does my render look different than the viewport?
The viewport OpenGL shading is intended to show only the textures in the Texture List and their respective
mattes. All of the rendering attributes such as facing ratio are computed at render time for Mental Ray and VRay since they use raytracing to create the final matte.

I'm seeing what appears to be compositing issues with multiple layered textures. Why is this happening?
If your issue is related to the rendered image, you could be running into transparency depth limits. The
Mattepainting Toolkit uses raytracing for rendering, so the limits must be set high enough in the Render
Settings to account for all the texture layers. If your issue is related to Viewport 2.0, try adjusting the
transparency settings for the viewport.

