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OVERVIEW

About

The Glyph Software Mattepainting Toolkit (gs_mptk) is a plugin suite for Autodesk Maya that helps 
artists build 2.5D and 3D environments from multiple camera projections.  First conceived during 
production on David Fincher’s “Zodiac” and later implemented in “The Curious Case of Benjamin 
Button,” it was developed to increase the efficiency of modeling and rendering scenes that rely heavily 
on reprojected mattepaintings.  It is now in use by both individual artists and large visual effects 
production facilities around the world.

Why use gs_mptk?

When texturing geometry in Maya, it is often preferable to use camera projections over UV 
placements, but the limited toolset Maya provides is unintuitive and labor intensive.  Combining 
multiple projections is cumbersome and requires extra effort to paint holdout mattes to define explicit 
boundaries.  Projection smearing, doubling on backfaces, and loss of resolution over large surface 
areas are common problems that take time to patch.

gs_mptk removes the technical burdens of setting up projections in Maya and allows artists to focus 
on the composition of the imagery.  The advanced blending features of the toolkit are designed to 
target the challenges of integrating multiple projections, and reduce the number of mattes needed to 
isolate geometry.

gs_mptk was built for mattepainters and texture artists, not programmers.  A lot of consideration went 
into designing a system that functions in an intuitive way, implements time-saving features, and 
minimizes repetition.  

What's included in gs_mptk?

gs_mptk consists of a UI that manages connections to custom Mental Ray shaders.  It is lightweight 
and easily installed on multiple systems and render farms.

gs_projCamMix is the dynamically-loaded mental ray shader that forms the foundation of         the 
Mattepainting Toolkit and allows multiple projections to be blended based on a number of user-defined 
parameters.

gs_viewportProj is the maya plugin that visualizes projections in the viewport using OpenGL.



gs_mptk_UI.mel is the MEL script that loads the interface to manage connections into 
gs_projCamMix and provides additional features.

gs_const is an optional constant shader that simplifies the use of alpha channels in renders.

What does it do?

Simply, it blends multiple camera projections, in the order they are assigned, based on the blending 
parameters given to each projection.  gs_mptk uses occlusion masking to determine which areas of a 
model are unseen by a projection camera, and patches these areas with other projections, based on 
their order of priority.  gs_mptk also supports masking based on a model's incident angle, distance, 
and miLabel*.

*miLabel is a custom attribute that can be assigned to any geometry shape, which is then read by 
Mental Ray at render time.

Requirements

Maya 2010 or 2011 SP1

Window, OSX, or Linux

A note about the demo version

The gs_mptk demo has the following limitations:

• The gs_viewport_proj has a watermark in the viewport.

• Rendering with gs_projCamMix will display a red noise pattern over half the image.

FEATURES

What's new in this release?

• Completely redesigned UI to simplify the projection workflow.

• Viewport OpenGL implementation of projections, including gamma conversion for linear workflow.

• Preview thumbnails of projections in the UI.

• Click on a thumbnail preview to automatically launch your preferred image editing software and load 



the texture.

• Quickly make shader assignments and swap node connections without navigating the Hypershade.

• Drag/drop interactive reordering of projection priority.

• Applied object list quickly adds/removes/selects which geometry is assigned to which projection 
group. 

• Easily toggle shadow occlusion on and off.

• Passthrough projection toggle enables/disables projections without removing them from a 
projection group.

• Color correct projections in Maya without directly editing the file textures.

• Tabbed layout allows for quick editing of multiple projection groups.

• Select projections, cameras, and mattes within the interface to avoid hunting for them in the 
scene.

• Batch update filter settings for all files in a projection group.

• Speed improvements.

• Unlimited custom mattes can be added to projections.

• Adding a new file projection detects alpha channels and automatically allows the user to add it to the 
matte list.

• Multiple channel (R, G, B, or A) support for mattes.

• Shadow occlusion now respects transparency maps.

• gs_projCamMix allows up to 20 mattes to be output to another shading node.

• miLabel exclude option allows geometry to be held out of a projection based on an int value.

• Distance threshold allows geometry to be held out of a projection based on its distance to the 
projection camera.

• gs_const shader added for ease of use and alpha channel support.

Fixes

• Lights are no longer necessary to create shadow occlusion areas; shadow occlusion is calculated by 
the shader.

• gs_projCamMix array naming/numbering mismatch has been fixed.



• Projections now default to film gate instead of resolution gate.

• Hypershade swatches bug that crashed Maya is fixed.

• Facing ratio function modified to generate masks that return either 1.0 or 0.0 based on angle 
threshold.

• Shadow occlusion no longer improperly introduces light into the scene.

Deprecations

• HUD deprecated due to new 2011 pan/zoom camera features.

• gs_shadow deprecated due to new occlusion masking algorithm.

• Shelf tabs deprecated due to new UI.

INSTALLATION

The following paths are indicated as default Maya install locations.  Alternative setups may require 
different install locations.  Administrative privileges may be required to install, depending on your 
platform configuration. 

The installation of the OpenGL Extension Wrangler Library (glew) is required for the gs_viewportProj 
plugin.  A platform-specific binary is included in the glew folder, and can be copied with the instructions 
below.  Alternatively, you can download the latest release of glew.

OSX 

copy contents of icons folder to: 

/Users/Shared/Autodesk/maya/2011/icons 

copy contents of scripts folder to: 

/Users/Shared/Autodesk/maya/2011/scripts 

copy contents of plug-ins folder to: 

/Users/Shared/Autodesk/maya/2011/plug-ins 



copy contents of mentalray/include to: 

/Applications/Autodesk/maya2011/Maya.app/Contents/mentalray/include 

copy contents of mentalray/lib to: 

/Applications/Autodesk/maya2011/Maya.app/Contents/mentalray/lib

copy contents of glew folder to:

/usr/lib/

* Tip: press COMMAND+SHIFT+G to navigate to /usr/lib easily

make symlinks to libGLEW.1.5.7.dylib: 

from a terminal, run the following two commands as super user: 

sudo ln -s /usr/lib/libGLEW.1.5.7.dylib /usr/lib/libGLEW.1.5.dylib

sudo ln -s /usr/lib/libGLEW.1.5.7.dylib /usr/lib/libGLEW.dylib

WINDOWS 

Notes: 

* $USER in the paths below is the username on your machine.  

* If you are running x32, the directory 2011-x64 in the paths below is named 2011. 

* The paths below are given for Windows 7.  Other versions of Windows may have different paths. 

copy contents of icons folder to: 

C:\Users\$USER\Documents\maya\2011-x64\prefs\icons 



copy contents of scripts folder to: 

C:\Users\$USER\Documents\maya\2011-x64\prefs\scripts 

copy contents of plug-ins folder to: 

C:\Program Files\Autodesk\Maya2011\bin\plug-ins 

copy contents of mentalray\include to: 

C:\Program Files\Autodesk\Maya2011\mentalray\include 

copy contents of mentalray\lib to: 

C:\Program Files\Autodesk\Maya2011\mentalray\lib 

copy contents of glew folder to: 

*for 32-bit Maya: 

C:\Windows\system 

*for 64-bit Maya: 

C:\Windows\system32 

LINUX 

Notes: 

* $USER in the paths below is the username on your machine.  



copy contents of icons folder to: 

/home/$USER/maya/2011-x64/prefs/icons 

copy contents of scripts folder to: 

/home/$USER/maya/2011-x64/prefs/scripts 

copy contents of plug-ins folder to: 

/usr/autodesk/maya2011-x64/bin/plug-ins/ 

copy contents of mentalray/include to: 

/usr/autodesk/maya2011-x64/mentalray/include 

copy contents of mentalray/lib to: 

/usr/autodesk/maya2011-x64/mentalray/lib 

copy contents of glew folder to: 

/usr/lib64 

make symlinks to libGLEW.so.1.5.7: 

from a shell, run the following two commands as super user: 

ln -s /usr/lib64/libGLEW.so.1.5.7 /usr/lib64/libGLEW.so.1.5 

ln -s /usr/lib64/libGLEW.so.1.5.7 /usr/lib64/libGLEW.so 

 

To run gs_mptk: 



1) launch Maya 2011 

2) load both gs_projCamMix mental ray shader and gs_viewportProj maya plugin: 

Window>Settings/Preferences>Plug-in Manager>gs_viewportProj 

Window>Rendering Editors>mental ray>Shader Manager>gs_projCamMix 

3) source gs_mptk_UI.mel from the script editor.

THE UI

The UI is loaded by sourcing gs_mptk_UI.mel through the script editor.  

Make sure the gs_projCamMix shader is loaded in Window>Rendering Editors>mental ray>Shader 
Manager, or the script will return the error:

Unknown object type: gs_projCamMix

Make sure the gs_viewportProj plug-in is loaded in Window>Settings/Preferences/Plug-in Manager

When the UI loads, all gs_projCamMix nodes existing in the current scene are loaded into a tabbed 
layout as projection groups.  The projections and matte connected to each projection group are also 
displayed, along with their attributes and assigned object list.

Menus

File

Import... - will import either a bundler (bundle.out) or PLY (.ply) point cloud.  Note that 
the PLY format supports a number of different types of topology, but only PLY files with 
point cloud data can be read.  The following is an example PLY file that can be 
successfully read by gs_mptk:

ply
format ascii 1.0
element vertex 2
property float x
property float y
property float z
property float nx
property float ny
property float nz
property uchar diffuse_red
property uchar diffuse_green
property uchar diffuse_blue
end_header
0.46268 4.46121 -6.76832 -0.0737488 -0.99675 0.0324225 199 197 193
0.476784 4.4728 -6.73427 -0.499492 -0.863363 -0.0714964 197 195 191



When importing PLY files, it is sometimes preferable to specify a step size to under 
sample the data.  Large data sets can take a long time to import, so increasing the step 
size will allow you to sample a fraction of the points.  A step size of 2 will import 1/2 of 
the data, a step size of 3 will import 1/3 of the data, and so forth.

gs_mptk also supports reading Bundle.out files created by Bundler.  These files contain 
both camera information as well as point data.  In order to properly set the focal length 
of the cameras, you must supply gs_mptk with the width of the images used by Bundler 
to calibrate the cameras, as well as the sensor size of the camera used to take the 
photographs.

New Shader - will create a new gs_projCamMix node.

RefreshUI - will refresh the UI to update any changes not made within it.

Create coverage map - will render a coverage map from the current viewport 
perspective that shows which areas of the selected geometry are visible to the selected 
camera over the time range specified in the timeline.  Select a camera and a any 
number of objects before invoking this command.  The resulting render respect the 
settings of the Render Globals.

Close - close the UI.

Options

    File Filtering - will set all files associated witht the projection group to the selected 
filtering method.

Viewport Lin to sRGB – for projections in linear color space, this toggle will enable 
gamma conversion to sRGB color space.

    Debug Mode - enable to print messages to the Script Editor for any modifications         
made to the projections through the UI.

Debug Step - enable to pause after each command is invoked during modifications 
made to the projections through the UI.

Help

    About... - display the version of gs_mptk

Tabbed Layout

The tabbed layout has three buttons for creating, removing, and selecting projection groups.  A 
projection group is comprised of a gs_projCamMix node and all of its incoming connections.  Each 
gs_projCamMix node in the scene is represented in the tabbed layout.



    +    Add a new projection group.  This will create a gs_projCamMix node with a basic setup, 
including a file projection for the color and ramp for the mask.

   -    Remove a projection group.  The projection group of the currently selected tab will be 
removed.  All nodes with connections to the group, except cameras, will be deleted.

    ^    Select the projection group.  This will select the gs_projCamMix node of the currently 
selected tab.

Projection List

The projection list represents all of the projections connected to the color inputs of the gs_projCamMix 
node.  The images projected in this list will constitute the RGB of the render.  The list is in a top-down 
priority, so that projections higher in the list have greater priority at render time.  In other words, 
projections are layered on top of each other from the bottom of the list to the top.

Projections are made current by the > button.  When a projection is made current, it is highlighted light 
gray, and all of its attributes, as well as its matte list, are displayed in the middle pane of the UI.

    +    Add a new projection.  A new file projection is added to the projection group, with 
priority over the current projection.

    -    Remove the current projection.  The current projection is deleted.

    ^    Select the projection.  The current projection is deleted.

Each projection in the list has a thumbnail preview on the left, a name that corresponds to the 
projection node itself (editable), the path to the image on disk (editable), a button labelled “...” to 
browse for images on disk, and a button labelled “>” to make the projection current in the list and 
display its attributes.

In Windows and OSX, the projection image can be edited by clicking on the thumbnail preview.  This 
will launch the image editor specified by the user in 
Window>Settings/Preferences>Preferences>Applications.  This feature is not available by default in 
Linux.

When a file texture with an alpha channel is added to the projection with the “...” browse button, its 
alpha channel is detected and the user has the option to add the alpha channel to the Additional 
Mattes list.  Note that a file’s alpha channel is not detected when editing the path field directly.

Projections in the list can be reordered by middle-mouse dragging them to the desired position. 
Projections can be swapped by shift-middle-mouse dragging from one index to another.  Note that the 
drag-drop area of the projections does not include the field areas.

When a projection is added to the list, a gs_viewportProj hardware shader is added to visualize the 
projection in the viewport.  Similarly, when the ^ is used to select a projection, it will be displayed in the 
viewport, overriding the previous viewport projection.  

Projection Attributes



    Camera

        The + button will assign the currently selected camera to the current projection.  The 
camera name will be assigned to the button on the right, which will in turn select the 
camera when it is pressed.

    Color Offset

        This color picker will add color to the current projection image.  It is useful to help 
balance projections that have a slightly different value from others in the list, or to make 
radical changes that expose the projection’s contribution in a render.

    Pass Through

        This check box will bypass the current projection at render time, effectively removing its 
contribution to the projection group.

Matte Attributes

    Distance Threshold

        When this field is set > 0, the current projection will only project onto geometry that 
falls at a cm distance less than the value set.  This value is always read as cm, and 
does not convert to other working units set in the preferences.

    Use Shadow Occlusion

        When checked, geometry not seen by the projection camera are masked at render 
time.  These masked areas will be filled by the next projection in the list if it is visible 
to the camera of that projection.  In this way, the gs_projCamMix shader works from 
the top of the projection list down to the bottom, filling in masked areas with the next 
projection that is able to “see” them.  This feature is called “shadow occlusion”             
because the projection camera acts like a light to determine what areas of the             
geometry are shadowed.  In order for this feature to work, raytracing must be             
enabled in the Render Globals.  The following attributes are enabled with shadow 
occlusion:

       

        Dilate

            This attribute will expand the shadow area.  Since it is often difficult to have a 
perfect correlation between the edges of a projected texture and geometry edges, the 
dilate attribute can conceal edge bleeding by expanding the shadow mask.

        Samples

            This attribute sets the number of samples per pixel for the shadow mask.  It                 
should be enabled only when Soft Edge is > 0.

       Soft Edge



            This attribute creates adds feathering to the dilated shadow area.  It is bound to a 0-1 
range, where 1 is maximum feathering.

        Power

            This attribute adds density to the Soft Edge.  It is often preferable to                     
increase the Power when using Soft Edge to ensure that the dilated area produces a 
solid matte at the geometry’s shadow boundary.

        You can think of the Shadow Occlusion attributes like this:

        The geometry’s shadow boundary is the hard edge between the visible and invisible areas 
seen from the projection camera.  When you dilate this shadow area, you are masking areas 
that are seen by the projection camera, and allowing other projections lower in the projection 
list to try to fill this area.  By enabling Soft Edge, you are adding transparency into this dilated 
area, but not the hard shadow area that is not seen by the projection camera.  With 
transparency in the mask, a percentage of the current projection’s contribution will be mixed 
with the projections lower in the list that are able to see this dilated area.  The Power 
attribute weights the percentage blending in the favor of projections lower in the list. Increasing 
the Samples will produce a smoother (less noisy) blend at the expense of render time.

    Use Facing Ratio

        This attribute will prevent the current projection from projecting onto geometry             
backfaces when Angle Threshold = 90.  If Angle Threshold < 90, areas of the             
geometry visible to the projection will be masked as well.  Facing Ratio produces a 
mask with a value of either 0 or 1, depending on the Angle Threshold.

        Angle Threshold

            The Angle Threshold extends the backface culling to include front faces,                 
based on the angle between the camera view vector and the geometry                 
normal.  It is specified in degrees, from 0 to 90.

        It is often advantageous to use backface culling with projections, and this is achieved by 
enabling Facing Ratio and setting the Angle Threshold to 90.  Sometimes, however, it is also 
necessary to mask geometry that is visible to the camera at a grazing angle so that 
projected textures do not smear across the geometry.  This is achieved by setting the Angle 
Threshold < 90.

    Label Exclude

        To exclude geometry from the current projection, add an attribute named “miLabel” 
to the geometry shape and set it to the Label Exclude value.  At render time, geometry 
with an miLabel value will be excluded from any projection with a matching Label 
Exclude value, but other projections will still contribute.  To add a miLabel value, 
select the geometry shape you want to exclude, and go to Modify>Add Attribute...  Set 
the Long Name to miLabel and the Data Type to Integer.  Note: make sure you add the 
miLabel attribute to the geometry shape, not the geometry transfrom.  gs_projCamMix 
will not recognize the label exclude if it assigned to the geometry transform.

Additional Mattes



    The Additional Mattes list is organized the same way as the Projection List, except that 
it does not have drag/drop functionality.  All mattes in the list are multiplied together 
before they are connected to the gs_projCamMix node, so there is no need for order of 
priority like the Projection List.  

When a matte file is loaded with the “...” browse button, the user has the option of choosing     
which channel in the image will be used for the matte.  In this way, it is possible to have up 
to 4 separate mattes (R, G, B, and A) in each file.  All mattes in the list project from the         
same camera as the current projection.

The Additional Mattes list applies only to the current projection, and is included as a way for 
users to generate custom mattes that mask areas not defined by the Matte Attributes.

    +    Add a matte projection.

    -    Remove the current matte from the list.

Object List

 This list displays the names of all objects (geometry) associated with the gs_projCamMix         
node.  Since the gs_projCamMix node is identified as a Mental Ray texture, it does not         
have a shading engine and does not make direct shading assignments.  Instead, an output     
connection is made between the gs_projCamMix node and another shader that is             
assigned to the geometry.  In this way, the gs_projCamMix node can easily fit into a         
pipeline that has custom shaders.

    It is necessary to add geometry to the Object List in order for them to render.

    The Object List allows for multiple selections by either click-dragging, shift-clicking, or, for         
non-contiguous selections, ctrl-clicking (cmd-clicking on OSX).

    If shader assignments are made to geometry outside of the UI, it is necessary to refresh         
the UI in order to see these changes reflected in the Object List.

    +    To add an object to the Object List, gs_projCamMix must have at least one 
outgoing connection to a shader connected to a shading engine.  If no outgoing 
connections are found, a default gs_const shader is created and connected 
to .outColor of the current gs_projCamMix node.

        This button can also change shader assignments to objects already in the 
Object List.  For example, if there are multiple outgoing connections from 
gs_projCamMix to different shaders, any object in the list can by 
assigned to a different shader because the list of connected shaders is 
invoked every time the + button is pressed.

        Note that only shaders with incoming connections from gs_projCamMix and 
outgoing connections to shading engines are detected by the + button.  Shaders 
are connected to shading engines by default when they are created through the 
Hypershade, so this is not usually an issue.



    -    This button will remove the shader assignment from the geometry selected in 
the list.

    ^    This button will select the geometry selected in the list.

END


